PCS Electronics PCS Electronics - home page PCS Electronics  
RegisterSearchFAQAM & FM Radio transmitters shop UsergroupsLog in
PCI MAX 2006+ driver is out!
Goto page 1, 2, 3  Next
 
Reply to topic    PCS-Electronics Forum Index » PCI MAX transmitters View previous topic
View next topic
PCI MAX 2006+ driver is out!
Author Message
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post PCI MAX 2006+ driver is out! Reply with quote
I've just uploaded the PCI MAX 2006+ drivers for XP and 98/Me.

Anyone care to give them a go?

Consider it a beta and post any problems here so we can check them out.

RDS support is functional, too. If you have rds daughter board, that is.
In the future we'll add more PS fields as the encoder supports up to 40.

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128

Last edited by pcs on Mon Feb 04, 2008 4:37 pm; edited 2 times in total
Sun Apr 09, 2006 1:12 pm View user's profile Send private message Visit poster's website
LARVIC
New registered user
New registered user


Joined: 09 Apr 2006
Posts: 4

Post TRIED THE 2006 DRIVER BUT NO LUCK Reply with quote
I tried the new 2006+ driver with rds support , but it would not fully install. It says :

Cannot find the file `D:\Progra~1\Pcimax~2\wdreg16.exe`(Or one of its components);

I downloaded the Win98 version as Iam running win 98 on a p2 mmx.
I also tried on my p3 450 Mhz. Same error. So Ill reinstall the 2004 driver for now.


Last edited by LARVIC on Tue Apr 11, 2006 4:15 am; edited 2 times in total
Sun Apr 09, 2006 10:01 pm View user's profile Send private message
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
It works fine here and at least one other PC, let's see what others have to
say about it.

If there's a problem, I'll issue a fix tomorrow.

What system are you using? Did you DL correct version?

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Sun Apr 09, 2006 10:21 pm View user's profile Send private message Visit poster's website
normick
New registered user
New registered user


Joined: 10 Apr 2006
Posts: 4
Location: Norway

Post Reply with quote
Bad news. 2006+ driver is not working. None of the drivers are working EXCEPT the 2004 driver.
Card installed as described. And I'm a geek, so no mistakes on my side. I have also had all the types of PCI max up to this release.

The 3 error-codes will be posted as soon as I get home.


3,6 GHZ dual pro
1 GB Ram
Fujitsu-Siemens Scaleo T Applause
Mon Apr 10, 2006 8:38 pm View user's profile Send private message Visit poster's website MSN Messenger
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
It works on my test system and on Peters' system. However, I have a lot of stuff installed here
and perhaps you don't have a dll or something on your PC that I do.

Error messages will tell us more.

By the way, it might be wise to remove any inf files starting with pcimax as the old driver
might be conflicting.

Just a proof so you don't think I'm making this up:





Works the same on Peters' pc.

Yes, PLL step is 50KHz now

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Mon Apr 10, 2006 9:30 pm View user's profile Send private message Visit poster's website
Sir Nigel
Moderator
Moderator


Joined: 28 Nov 2003
Posts: 334
Location: us.gif
us.gif

Post Reply with quote
pcs wrote:
It works on my test system and on Peters' system. However, I have a lot of stuff installed here
and perhaps you don't have a dll or something on your PC that I do.


I think that might have been the issue with the 2005 version of the driver.

Glad to know it's out. I'll try and test it soon.

_________________
-empty-
Mon Apr 10, 2006 10:33 pm View user's profile Send private message Visit poster's website
normick
New registered user
New registered user


Joined: 10 Apr 2006
Posts: 4
Location: Norway

Post Reply with quote
Looks good on yours. Too bad mine doesn't except the 2004 driver which seems to be the winner of all drivers.

Even though I change slots and everything and following the manual CAREFULLY - I get this:

*Unable to open pci max card. Last reported error I/O error 105*

next
*Acess violation at adress 004696FF in module pcimax2006+.exe - read of adress 00000070*

Everything is done by your step-by-step guide. Slots have been changed. ONLY 2004 driver works. I think I will go retro!

PS all the old drivers are of course removed from all locations.
And the card itself looks good on the SYSTEMLIST in controlpanel.


Last edited by normick on Tue Apr 11, 2006 12:38 am; edited 1 time in total
Tue Apr 11, 2006 12:02 am View user's profile Send private message Visit poster's website MSN Messenger
normick
New registered user
New registered user


Joined: 10 Apr 2006
Posts: 4
Location: Norway

Post 2004 driver VS amp Reply with quote
Is it true that the 2004 driver does not give full effect on the 2006+ card? (I have the 1000mW card)
Then it is even more important to fix the 2006+

Happy easter Radio Geeks.
Tue Apr 11, 2006 12:36 am View user's profile Send private message Visit poster's website MSN Messenger
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
You can try this: Keep the exe from 2006 and install 2004 driever.
Now when you run exe from 2006 it should work.

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Tue Apr 11, 2006 9:23 am View user's profile Send private message Visit poster's website
Nick
New registered user
New registered user


Joined: 22 Dec 2005
Posts: 6

Post Not much luck with the new driver Reply with quote
Hi

Tried the new driver (XP version) - it's partially loaded but won't run.

I can see that it's registered in the Device Manager (as in your screen shot - it's shown as PCI Max 2006+ under Jungo - and the device is decribed as functioning properly).

But when I try to fire up the driver, I get:

"Unable to open PCI Max card. Try to move PCI Max to another PCI slot or reinstall the driver. Last reported error: I/O errror 105"

followed by:

"Access violation at address 004696FF in module 'PCImax2006+.exe'. Read of address 00000070."

I've tried re-installing the driver, and trying the other slot. No luck.

If I'm to use the 2006 exe file in a 2004 installation, would the following process do it. Copy the 2006 exe file to a new location, uninstall the 2006 driver, reinstall the 2004 driver and get that working again. And then copy the 2006 driver into the 2004 folder. Would I have to alter any registry values or delete the 2004 exe file and rename the 2006 file?

In doing all this, I've cleaned out my system, used Registry Mechanic and Window Washer etc and deleted all residual traces of the 2004 driver by hand.
Thanks for all the support!
Tue Apr 11, 2006 10:51 am View user's profile Send private message
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
hi!

Situation is becoming interesting.
I've now had someone email me and tell me the new driver solved their problem.

But let's work on this together to fix any potential problems for everyone and create
universal solution that'll work for everyone, such as an updated driver.

The problem could only be with the inf files, just make sure to remove any old
pci max inf files. No need to fiddle with the registry, can't see any benefit from
doing that. The other potential problem could be from not rebooting after all this
re-installing. Probably not the case here?

Now, I'm wondering if it'd help if you moved card to another slot?
The error message you've seen means the program can't communicate with the
card. In my PC I had a problem before, pci max would only work in a slot
which was occupied by wlan card. And wlan card would also only work in this
slot. So I had to remove wlan card to test pci max. Now with 2006+ driver it works
in other pci slots, but I haven't tested it in the wlan-occupied slot yet.

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Tue Apr 11, 2006 11:23 am View user's profile Send private message Visit poster's website
Nick
New registered user
New registered user


Joined: 22 Dec 2005
Posts: 6

Post Reply with quote
Hi!
Thanks for the quick response. Yes, I followed the earlier suggestions and rooted out all INF and other files that I could find from the old 2004 installation (which did work - although it occasionally fell over and had to be re-installed). The only related INF files on the system are the 2006 INF and windriver INF files - which are in quite a few folders (but all dated 2006).

I checked the registry to make sure that the un-installation had done the job (it hadn't).

And, yes, I do a full reboot (and power down) after each change.

I've just had another go at re-installing - by updating the driver through Device Manager - and then by using the repair function in the new driver under Add/Remove Programs. No luck either way (again, I rebooted after each change)..

Looking in Event Viewer, I see "The WinDriver service failed to start due to the following error: The system cannot find the file specified." and
"The HID Input Service service terminated with the following error:
The system cannot find the file specified." It does not tell me which file cannot be found, though!

The windriver error may be related - not sure about the HID Input one. But both happen at the time the driver fails - and are repeatable. No security or application events to report.

Hope that helps. Cheers! I am off to bed as it night-time, it's autumn and it's cold down here.
Tue Apr 11, 2006 12:06 pm View user's profile Send private message
Nick
New registered user
New registered user


Joined: 22 Dec 2005
Posts: 6

Post Reply with quote
Forgot to mention - I swapped the card around. I only have 2 free slots - and have been alternating between them. Whenever the 2004 driver fell over, I'd just pop it in the other slot - and re-install the software. That worked fine for that driver - should work for this (but doesn't seem to).

I don't really want to move other cards around such as the video card as they work fine where they are.

Cheer, Nick
Tue Apr 11, 2006 12:10 pm View user's profile Send private message
normick
New registered user
New registered user


Joined: 10 Apr 2006
Posts: 4
Location: Norway

Post Reply with quote
I have the same experience as nick with all the same error codes.
The 2006 driver is mentioned as 2005 driver i registry.

Marko, will the 2004 powerslider give as much effect as the 2006+ driver iis supposed to on the 1W card?
Tue Apr 11, 2006 12:46 pm View user's profile Send private message Visit poster's website MSN Messenger
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
The power slider works the same, so the new driver will not give you more power or change the
audio in any way.

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Tue Apr 11, 2006 1:48 pm View user's profile Send private message Visit poster's website
Nick
New registered user
New registered user


Joined: 22 Dec 2005
Posts: 6

Post Reply with quote
Hi

Just delved some more into the error messages. I don't think the installation routine has properly installed windrvr6.sys. I ran the following:

"C:\sc query windriver.sys
[SC] EnumQueryServicesStatus:OpenService FAILED 1060:

The specified service does not exist as an installed service"

and

"C:\sc query windrvr6.sys
[SC] EnumQueryServicesStatus:OpenService FAILED 1060:

The specified service does not exist as an installed service"

I checked using the Services tool under Administrative Tools, and there's no serivce of that name there. For the 2004 driver I think I used to also see something like windriver6.sys listed in System Devices under Device Manager. There's nothing there now.

I can email you the install.txt file from the program folder if that would help (couldn't spot any obvious eror messages in that).

Hope that helps
Wed Apr 12, 2006 10:18 am View user's profile Send private message
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
Try running this:

wdreg -inf <path to windrvr6.inf> install

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Wed Apr 12, 2006 10:41 am View user's profile Send private message Visit poster's website
Nick
New registered user
New registered user


Joined: 22 Dec 2005
Posts: 6

Post Reply with quote
EXCELLENT!

That's solved it (but I had to run it from within the PCI Max 2006+ folder as it wouldn't accept the path statement). It worked without needing a re-boot, and windriver now shows up as a service. I'm now back on air!

Many thanks for the prompt service, the spot-on problem-solving and for the excellent product!
Wed Apr 12, 2006 10:57 am View user's profile Send private message
pcs
Site master
Site master


Joined: 18 Jan 2002
Posts: 3063
Location: Radio Land

Post Reply with quote
Ok, the install runs this file at the end, but uses path to system32 as well.

So maybe I need to run it locally inside pcimax2006 installation program.

I'll upload the new driver in a couple of days, with this fix added.
In the mean time run it manually.

_________________
Best regards,
Marko - PCS Electronics
--------------------------------------------------------
Turn your PC into a FM radio station!
http://www.pcs-electronics.com
fax +386 4 2316 128
Wed Apr 12, 2006 4:12 pm View user's profile Send private message Visit poster's website
erobertg
Compulsive poster:)
Compulsive poster:)


Joined: 29 Oct 2004
Posts: 113

Post Reply with quote
It's about time, so far the 2006 driver seems to to be working well.

I noticed that the software comes in two flavors, Windows XP and earlier Windows 98/ME version.

I also noticed that my Window XP now reports PCI MAX 2006+.

On boot up though I get a bios message that alerts me to bios error that I must disregard, but entering Windows the card still works fine.

You have also added 50 kHz steps, is that to cover frequency error?

How much error if any exists between reported and actual frequency?
Wed Apr 12, 2006 4:33 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    PCS-Electronics Forum Index » PCI MAX transmitters All times are GMT + 1 Hour
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group